Installation for Linux

Please download the wallet installation package from the official website http://downloadwallet.lbtc.io/index.php/s/w9qmzkULkbmK8Yi/download. The wallet now supports Linux 64bit system.

Take version v1.1.1 on Ubuntu 16.04 as an example.

Download

Download standard version

# For tar.gz balls
wget http://downloadwallet.lbtc.io/index.php/s/w9qmzkULkbmK8Yi/download
tar -xzvf lbtc-fullnode-wallet-ubuntu16.04-x64-v1.1.1.tar.gz

Install dependencies

sudo apt-get -y install libzmq5
sudo apt-get -y install libevent-dev
sudo apt-get -y install libboost-chrono-dev
sudo apt-get -y install libboost-filesystem-dev
sudo apt-get -y install libboost-program-options-dev
sudo apt-get -y install libboost-dev

Run

# Option '-d' run as daemon mode
./bitcoind -d

# Get helps from bitcoind
./bitcoind help

# Get version number
./bitcoind -version

# Get helps from bitcoin-cli
./bitcoin-cli help